Mozilla dropper support til NPAPI-plugins

Mozilla dropper support til NPAPI-pluginsGoogle Chrome viser ikke længere ikke-essentiel flash (som eksempelvis reklamer), Safari viser ingen flash overhovedet og Microsofts nye Edge-browser har helt lukket døren til NPAPI-plugins.

Det samme har Mozilla, der står bag den populære Firefox-browser, nu planer om at gøre.

Mozilla har meddelt, at de om cirka et år vil stoppe med at understøtte de såkaldte NPAPI-plugins. NPAPI – Netscape Plugins Application Programmering Interface – kaldes af Google Chrome for ”en tung hammer”, der kun skal bruges, når ingen andre former for kode og applikationer kan løse behovet. Med den teknologiske udvikling er anvendelsesområdet for de usikre og performance-krævende NPAPI-plugins blevet mindre og mindre, hvilket nu leder Mozilla til helt at droppe dem.

Men Flash bliver

Til manges overraskelse har Mozilla dog valgt fortsat at understøtte den krævende flash-teknologi.

Apple har helt bandlyst flash fra deres enheder, da teknologien sluger meget strøm og med HTML5’s mange muligheder ikke er nødvendig, hvis du har en dygtig nok programmør.

Chrome tillader ikke ”non essential flash”, som bl.a. dækker over reklamer og andre elementer, der ikke er strengt nødvendige for at holde en side kørende. Google som firma har i lang tid haft et horn i siden på flash-teknologien, da Google ikke har mulighed for at indeksere sider bygget i flash. Vi har oplevet flere eksempler i OnlineSynlighed.dk på store danske webbureauer, der har bygget flotte og dyre flash-løsninger til deres kunder for så at opdage, at strømmen af besøgende fra Googles organiske søgemaskine fra det ene øjeblik til det andet nærmest er ophørt.

Web bliver platformen i fremtiden

I fremtiden vil vi ikke benytte os af plugins som flash eller java til at køre applikationer. Det hænger sammen med, at internettet og HTML5 i sig selv er så stærk en platform, at behovet for eksterne plugins med tiden er faldet.

De eksterne plugins repræsenterer især en stor sikkerhedsrisiko. Java, som NemID indtil for nyligt har været alene baseret på, har været kilde til mange indbrud i Nem-ID-systemet. Det, og det at java som teknologi kræver meget af browseren og computeren er grunden til, at en javascript-baseret model af NemID med tiden blev udviklet og i dag bruges som den primære løsning af bl.a. banker og det offentlige. Hvis du bruger Google Chrome som browser er det end ikke muligt at bruge NemID i dag siden version 42 af Chrome, der blev frigivet tilbage i april 2015.

For år tilbage var NPAPI-plugins nødvendige for bl.a. at afspille video, spille spil og se avancerede grafikker. Udviklingen af HTML er dog gået stærkt og de største platforme i verden anvender slet ikke flash længere. En foregangsside på området er YouTube, der var blandt de første videosider i verden til helt at skifte over til HTML5 med stor forbedring i sidens performance som umiddelbart resultat.

NPAPI blev i sin første version udviklet af Netscape-browseren – datidens mest populære browser indtil Internet Explorer kom – tilbage i 1995 og har således fejret 20-års jubilæum fornyligt. Det er 10x længere end de fleste onlineteknologier får lov til at leve.

Du kan til enhver tid trække dit tilsagn tilbage

Mozilla dropper support til NPAPI-plugins